Questions tagged as ['usb']

USB is an acronym for Universal Serial Bus. The current USB standard is USB 3.0, which supports transfer speeds of up to 625 MB/s. USB devices are plug-and-play.
Score: 1
Lukas avatar
sdb Attached SCSI disk. But I can't find it anywhere
fr flag

I'm trying to attach external HDD with a new cable I bought on Amazon, JSAUX USB 3.0 to SATA Adapter.

syslog says it was attached as sdb, but I don't see it anywhere.

kernel: [ 2839.039779] sd 2:0:0:0: [sdb] Attached SCSI disk

tried

sudo fdisk -l
sudo parted -l

But the attached disk is absent.

If I try my luck and mount sdb anyway, I get error message below.

sudo mount /dev/sdb /media/external/
mount ...
Score: 0
Tom Riddle avatar
I want to remove broken files from an USB-Stick
cn flag

I tried setting up a backup on my USB-Stick but at some point it got randomly unmounted and now I have a folder with broken files. I also can't use the trash on the stick anymore because it says that the trash is full and when I try to remove them they just reappear. Then I tried to use GParted and KDE Partition Manager to format it, I tried the Repair tool on windows partition and tried to overwrite it ...

Score: 2
n0tis avatar
External monitor lead to screensaver in-out loop
us flag

Normal behavior:

After 1min of beeing IDLE, my laptop will show a blank screen to save power (not "suspend", just blank screen ) When the mouse is touched, the screen is back to life.

Abnormal behavior:

However, when my external monitor is plugged via a USB to HDMI adapter, this does not work correctly:

  • After 1min of IDLE, the computer screen goes black,
  • the external monitor detect the blank image, and a ...
Score: 0
Raj Dave avatar
USB Ethernet adapter refusing to work on Ubuntu Server
nr flag

OS: Ubuntu Server 20.04.5 LTS
Hardware: A laptop with i7-6500U & 16GB DDR4 1600

So I have this USB ethernet adapter, "VMAX VIA100 USB3.0 to RJ45". It works on every device other than this device. I have no idea what to try anymore

Info:

• Doing the lsusb command -

Bus 002 Device 002: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter

(The adapter is clearly detected)

 ...

Score: 0
Alejandro avatar
Set priority for bluetooth interface
mz flag

I just migrated from Windows to Ubuntu as my main OS. I own a bluetooth dongle which I use for connecting my wireless headphones to my computer. The thing is, my PC does NOT have integrated bluetooth, which is no problem since I use the dongle, on Windows I just had to plug it in and pair whatever device I wanted; when using Ubuntu for any reason it shows hci1 and is scanning for nearby devices as if ...

Score: 0
David Löwen avatar
on an Android/Windows Laptop after booting over USB to Ubuntu Android wont boot
mc flag

I have an old Tablet (Chuwi Hi 10 Pro) that has Android and Windows in dual-boot. I Booted over USB Ubuntu once and since then Android won't Start anymore it just hangs on the Starting screen. I don't know what to do, to make Android boot again, and because it's a weird Android version I don't know if I can find an Android version that works with that Tablet.

Score: 0
FedKad avatar
Files copied from an MTP device by Nautilus have their modification date set to epoch 0
cn flag

When I copy files from a USB connected MTP device (e.g. an Android phone) to a Ubuntu 22.10 computer, the modification dates of the files are lost: They are set to "Epoch 0".

This problem did not occur in previous (< 43.0) versions of Nautilus.

I tried the same with Thunar 4.17.9 and this problem did not occur there.

There are many other nasty bugs and usability problems in Nautilus version 43, whic ...

Score: 1
No-Question123 avatar
USB stick detected but no files are showing up
cc flag

I'm using ubuntu server and I'm trying to transfer files over usb but I'm having a weird problem. The usb stick is detected but no files are showing up. For example, I plugin the usb stick, I navigate to /media, I run ls, and nothing shows' up. I've even tried changing dirs to one that's on the usb stick and it just says that it doesn't exist.

things I've tried:

  • using a different os
  • using a different por ...
Score: 0
Mustapha Mambo avatar
I wanted to post a solution for: MicroSD card is set to Read-only state. How can I write data on it?
tn flag

MicroSD card is set to Read-only state. How can I write data on it?

I dont have 50 credits to add an comment. I had the same problem, and I yes, I tried several adapters and seveveral readers. One SD card seems screwed others behave fine. Screwed means: gparted, dd, and hdparm denied access with root permssions. (It was a sandisk ultra 16GB)

Then I put the microSD in an old USB-reader (from Trans ...

Score: 1
Arjun Tripathi avatar
Why my ubuntu 22.04 only charge my phone when it connect with usb?
ma flag

When i connect my android phone with usb to my ubuntu 22.04 laptop it charge my phone only not showing option of transfer file in my phone.

Score: 1
Mahesh Avula avatar
Coudn't able to read data from USB CDC-ACM port using cat command on ubuntu20.04 version
ir flag

I was working on USB2.0 version and i was given support for USB device as CDC-ACM and it's working fine when I read data from USB serial port as CDC-ACM using cat command(cat /dev/ttyACM0) on ubuntu version 18.04, but same thing if i read data on ubuntu version 20.04 couldn't able to see any data on serial port as /dev/ttyACM0.

But, When i read data through minicom rather than reading data using  ...

Score: 1
Apply udev rule on reboot if device is present
kr flag

This code must be executed each time my Keychron K1 keyboard is about to be used:

echo 2 > /sys/module/hid_apple/parameters/fnmode

The code enables Fn keys as the Keychron suggests on Linux.

I put it in a script /home/me/k1add

After hours of desperation I successfully wrote this rule:

SUBSYSTEM=="hid", ENV{HID_PHYS}=="*input0", ACTION=="add",
ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="024f", RUN="/ho ...
Score: 0
mokrota21 avatar
Black screen after switching from windows to ubuntu budgie
mn flag

I downloaded ubuntu budgie on usb, then installed ubuntu budgie and deleted windows from my laptop, afterwards it was loading and something like "plug off mediator and press enter" popped out so I plugged off usb and pressed enter. Then screen turned black, I was waiting for about 15 minutes, tried to turn off and turn on but it still is completely black. Is everything really bad or it is some minor pro ...

Score: 1
Leah Waymire avatar
My 2TB Hard drive stopped showing up
hn flag

I have checked lsusb, sudo fdisk -i, and eventually even my boot menu. No matter what it does not show up. I can hear the drive's fan working so I know it is receiving power, and the USB port is working fine. Any ideas what I could do?

Score: 0
Julius Babies avatar
How can I simulate a network interface if it's not connected
nl flag

I need to emulate a usb0 interface when it's not connected. I have a bridge from usb0 to wlan0 but my hotspot configured with hostapd doesn't work if usb0 isn't connected, I can't connect to the network. I have to attach my phone, enable USB tethering I want to be able to connect to the network when I didn't connect my phone. The network should connect to the internet as soon as I connect my phone wia a  ...

Score: 0
Showing USB drive in Dolphin
us flag

How can I examine the contents of a USB camera in Dolphin? The left column shows Places;Remote;Recent;Search For;Devices but it doesn't appear in any of these. The camera is listed in lsusb, so I know it's visible.I'm running Kubuntu 22.04.

What I'm really trying to do is to preview JPEG images as images in the file listing, but just seeing the camera files at all is the first step. In Configure/Ge ...

Score: 1
billo avatar
NIKON Z7 not recognized as MTP device
it flag

I am using kubuntu 22.04 on a laptop and am trying to connect to my NIKON Z7 via usb. I plug the device into my usb port, and it is recognized as a camera and I get the option to mount it. However, it really isn't mounted.

The error I get in /var/log/syslog is:

Nov 19 18:53:12 nunyopc kernel: [13797.573402] usb 1-4: new high-speed USB device number 33 using xhci_hcd
Nov 19 18:53:13 nunyopc kernel: [ ...
Score: 0
Viewing digital camera files in Dolphin
us flag

I'm trying to view the files on my Canon camera over a USB connection. The camera shows up in lsusb. but not in Dolphin's list of devices. When I first plug it in I get a window offering to connect it via File Manager, but it never shows up in a Dolphin window.

Update 1 Using the app gphotofs I was able to import the JPG files into a folder. So I've reduced the problem to this: given a folder of JPGs, d ...

Score: 0
threehappypenguins avatar
Boot to USB from Shell?
tr flag

I can't boot into the OS (I'm getting Oh no! Something went wrong.). I can boot into grub (and edit grub to open shell), or boot into recovery and open shell from there. Normally, I would just boot to USB and refresh/reinstall the system, but I can't. It's a 2010 MacBook Pro and it doesn't matter how many times I reset PRAM (option+command+P+R keys), it won't show the USB (I've done this several times b ...

Score: 0
Archer T4U AC1300 not working
US flag

I'm on Ubuntu 20.04, kernel 5.11.0-27-generic. Relevant line of lsusb: Bus 001 Device 003: ID 2357:010d TP-Link 802.11n NIC

As in Ubuntu 20.04 issues with TP Link AC1300 Archer T4U, I installed rtl8812au-dkms package, but wireless internet still doesn't work. Running ifconfig shows no wlan0 interface:

enp31s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.42.0.20  netma ...
Score: 0
mrpandey avatar
System resumes from suspend due to connection/disconnection of power supply. How to stop this?
us flag

I run Ubuntu 22.04 on my ThinkPad with swaywm as my DE. Recently, I noticed that my system wakes up from suspend (systemctl suspend) if the power input is interrupted (power goes out or comes back).

It happens irrespective of whether the laptop lid is open or closed during suspension. I disabled the lid switch in BIOS, but it still happens. This means lid has nothing to do with it.

To eliminate U ...

Score: 0
Hans Weijers avatar
Problems with USB Tethering on a Samsung XCover 5 (Android 12) and Ubuntu 20.04
fj flag

Ubuntu (20.04 with kernel: 5.15.0-53-generic) keeps connecting, but nothing happens. I think the smartphone (Samsung XCover 5 with Android 12) is not responding on a dhcp request. I see with ifconfig the RX errors count increasing.

When I use bluetooth tethering, but slow, the ubuntu system works fine with the same smartphone.

When I use usb tethering with a windows 10 system and the same cable then ...

Score: 1
James Harkins avatar
Ubuntu Studio 22.04 USB stick failing to mount volume
ci flag

I've downloaded ubuntustudio-22.04.1-dvd-amd64.iso from https://ubuntustudio.org/download/ .

sha256sums:

  • Reference checksum (online): 3fe6fa9a17fa7a4b34b2ec7ff3b9500d354ca644aedcc37096b923f14247f504
  • Checksum from the download: 3fe6fa9a17fa7a4b34b2ec7ff3b9500d354ca644aedcc37096b923f14247f504

AFAICS the download is intact.

I used unetbootin to create a bootable USB. The machine successfully loaded the GR ...

Score: 1
jhaagsma avatar
Slow USB ports (losing keyboard keystrokes) sometimes on Ubuntu 22.04
in flag

I recently upgraded to 22.04, and have since experienced extremely laggy USB ports, to the point where I lose keystrokes and much/most of the mouse movement input. I am using a USB switch primarily, as this is a server in a rack around the corner.

The baffling thing is that I occasionally get perfect connectivity after physically unplugging/replugging the switch on some ports, but this is not ent ...

Score: 1
vonnonn avatar
Adding sata power to USB PCIe card causes shutdown to restart instead
gm flag

Kernel: Ubuntu 22.04 MB: Supermicro H11DSI USB PCI3: Fresco Logic 1100

I was able to shutdown properly when sata was disconnected. I'm new to Linux so I don't know how to debug this. Any help would be great.

Cheers, Josh

Score: 0
pandaXcore avatar
bootable usb ubuntu 22.04 stuck on "Welcome to GRUB"
cn flag

Have an old HP Pavilion DV7 without UEFI. Trying to install an Ubuntu 22.04 it stuck at the beginning of booting "Welcome to GRUB". Can somebody help with advice, or salvation.

Score: 1
magenta avatar
Ubuntu 22.10 on USB Stick with no previous program or partitions but Bios has no USB option to Boot from
to flag

New Ubuntu user coming from Linux Cinnamon 20.3 trying to install Ubuntu 20.10 on my Hard Drive for the first time

Using Rufus I put Ubuntu 22.10 on a USB Stick all went well without problems as it was a Clean Transfer to the New USB Stick with no previous programs or partitions

The Problem is my Bios doesn't show any USB option to boot from, so I am completely lost as to what I should do

As a Newbie t ...

Score: 0
Rod avatar
Upgraded to Jammy Jellyfish, drives now cycle in and out of suspend whilst transferring data (TB at a time)
mp flag
Rod

Forgive me, I barely know enough at this point to have gotten 22.04.5 LTS installed along with Plex Media server.

I got home this morning and had a batch of files I have been meaning to transfer to my bulk storage drives in the system. I connected up my T5 USB and drag files/folders for copy to their destination. Drive 1 had a batch of about 500GB which I selected using the GUI in one motion an ...

Score: 1
Ed Delauter avatar
Following Ubuntu OS update and reboot serial ports not recognized inside Arduino IDE
gb flag

Serial ports ttyACM0 and ttyUSB* have disappeared after update to 20.04 LTS and reboot. Tried going from Grub kernel 5.15.0-52-generic to 5.15.0-48-generic. These particular ports are referenced inside the Arduino IDE 1.8.19 software platform. Is this somehow an issue with module uhci_hcd?

This output is currently what listing usb indicates:

ed@ed-G41MT-S2PT:~$ lsusb

Bus 001 Device 003: ID 046d:c52b Logi ...

Score: 0
Dalton avatar
Unusable USB-C Hub in monitor Dell P2723DE with Ubuntu 2204
gb flag

I have got Dell P2723DE with usb hub, PD3 etc.. but when I plugged in Lenovo laptop with ryzen 5800u and vega integrated graphics it disconnected few times while setting it up. After finishing setup it was working properly but for like 30 seconds max and after mouse click or some other random event it disconnected again and reconnected and continued with this behavior until I got mad and put it through  ...