Score:0

Block "ethash.poolbinance.com" on MikroTik

ru flag

Can you explain me. How I can block this address from firewall on MikroTik.

I just try to add the rules with only "poolbinance.com" and other rule with "ethash.poolbinance.com"

But it is not working.

Thank you for help.

full address looks like tcp://ethash.poolbinance.com:1800

djdomi avatar
za flag
found a nice tutorial via google: https://monovm.com/blog/block-url-on-mikrotik/
turtle avatar
ru flag
@djdomi Thank you for answer. I know this method. But problem is about to block connection from/to this address or ip. I try to block other sites like fb.. etc.. And it's work well.
djdomi avatar
za flag
i would just do a workaround, set up a dns zone locate it to 127.0.0.1 and force poolbinance.com to it, however since it is cloufflare behind, you may need to block cloudflare entirly to get rid off (Address: 172.65.8.243, Aliases: ethash.poolbinance.com, eth.poolabc.org.cdn.cloudflare.net) or as a second work around block port 1800 outbound
Score:0
hk flag

If your router is a DNS server for your clients, you can poll regularly DNS cache for poolbinance and block the corresponding IP:

Schedule this script every 10 seconds or so:

:global addIP do={
  :if ([:len [/ip firewall address-list find address="$nouvelleIP" and list="blockedIPs"]] = 0) do={
    /ip firewall address-list add list="blockedIPs" address=$nouvelleIP timeout=02:00:00
  }
}

:local myServers { "poolbinance" }
/ip dns cache all {
  :foreach i in=$myServers do={
    :foreach j in=[find where (name~$i)] do={
      :local myName [get $j name]
      :local myType [get $j type]
      :local myData [get $j data]
      :if ($myType = "A") do={
        $addIP nouvelleIP=$myData
       }

      :if ($myType = "CNAME") do={
        :local ipResolue [:resolve "$myData"];
         $ajouteIP nouvelleIP=$ipResolue
      }
    }
  }
}

And then add a firewall rule to block all traffic from blockedIPs list:

/ip firewall filter add action=drop src-address-list=blockedIPs
mangohost

Post an answer

Most people don’t grasp that asking a lot of questions unlocks learning and improves interpersonal bonding. In Alison’s studies, for example, though people could accurately recall how many questions had been asked in their conversations, they didn’t intuit the link between questions and liking. Across four studies, in which participants were engaged in conversations themselves or read transcripts of others’ conversations, people tended not to realize that question asking would influence—or had influenced—the level of amity between the conversationalists.